Archivi giornalieri: 13 settembre 2017

Aiuto, affogo!

La stazione meteo è ormai attiva da qualche tempo, e ha dato enormi soddisfazioni funzionando in modo perfetto per diversi mesi.

Qualche giorno fa c’è stato un violento temporale, con tanto di allagamento del parcheggio antistante casa. In corrispondenza di questo evento la stazione meteo ha smesso di funzionare. A prima vista un problema di comunicazione I2C, visto che i dati registrati erano tutti “0”. Riavviata la stazione non c’è più stata connessione.

Mi sono recato sul tetto ed ho smontato i coperchi. Lo scempio è completo:

  • Sezione di controllo allagata, con segni di ossidazione evidenti su alcuni connettori e “condensa” sul coperchio.
  • Sezione del sensore di pioggia completamente allagata con segni di condensa anche in questo caso e pesante ossidazione.

Cosa può essere successo? La scatola del sensore di pioggia secondario è realizzata con una scatola da esterni di tipo “economico”, senza pressacavi con guarnizione. In questa scatola è entrata acqua ed umido.

La scatola è collegata alla sezione di controllo attraverso un cavo dalla guaina piuttosto “rigida”, che ha fatto la funzione di “tubo”, facendo arrivare aria molto umida che si è condensata sulle pareti. Con il calo delle temperature, l’umido è aumentato tanto, arrivando a bagnare molto il circuito, rendendolo non funzionante.

Interventi di ripristino:

  • rendere la scatola del sensore secondario veramente “stagna” con silicone e nastro vulcanizzante, oppure rimuoverlo del tutto, visto che in definitiva serve a poco.
  • rendere la scatola dell’elettronica non comunicante con la scatola del sensore secondario, tappando il “tubicino” con il silicone.