Archivi tag: networking

GNS3 – che sofferenza!

Da un paio di giorni sto impazzendo per cercare di fare funzionare GNS3 sul mio calcolatore. GNS3 è una piattaforma estremamente potente di simulazione di reti di tipo multivendor.
Si basa su un eseguibile che viene eseguito sul sistema operativo del calcolatore e su una macchina virtuale sulla quale sono eseguite le immagini dei nodi di rete (usando diversi stili di virtualizzazione: dynamips, quemu, virtualbox etc..).

La prima installazione che ho provato ad eseguire è basata su VmWare player, software scaricabile liberamente dal sito di vmware. Dopo una infinità (numerabile) di tentativi ho desistito. Il problema sembra essere dato dalle API VIX, che sono necessarie a GNS3 per interagire con VmWare. Ho trovato diversi articoli in rete e su reddit che sembrano affrontare il problema ma non sono riuscito a risolvere il problema. Ottengo sempre questo errore:

Per questo ho desistito ed ho installato VmWare Workstation (anche di questo software è possibile scaricare un trial libero). Il vantaggio di questo approccio è che non richiede le VIX API, anzi debbono essere accuratamente disinstallate. Provato con Workstation, sono riuscito a fare funzionare tutto al primo colpo: ho caricato le immagini (persino quella Mikrotik, usando questo tutorial).
Attualmente nella TODO – LIST:
– fare una simulazione single-vendor e multi-vendor;
– cercare di importare VRP (sistema operativo dei dispositivi Huawei);
Stay tuned for more happy days!

Please follow and like us:
error

Network Monitoring

Casa nuova, nuova rete, vecchie manie. Come già avevo fatto tanti, tanti anni addietro, ho installato tutto il necessario per monitorare le prestazioni della mia rete domestica. Questa è composta da un NAS, un AP, una MikroTik ed un server, oltre al router che fornisce la connettività verso Internet.

Il server ho deciso di realizzarlo sfruttando una board che avevo comperato nel 2011 e mai utilizzato: la cubieboard 2. Si tratta di un embedded basato su ARM A20, molto interessante e dotato di una buona dotazione di porte, compresa una SATA. Il sistema operativo (Debian per ARM) risiede su una SD da 16GB. La cubieboard è il cuore della mia rete e funge da server MySQL e aggregatore dei dati SNMP. Sono molto soddisfatto del suo funzionamento.

Per visualizzare i dati e le prestazioni dei sistemi mi sono inizialmente avvalso di Cacti, un sistema che conosco abbastanza bene ed utilizzo con successo anche in ufficio. Parallelamente ho voluto anche sperimentare LibreNMS.

Cacti è un sistema consolidato, che ha dalla sua una discreta community di utenti e un forum di supporto. L’aggiornamento del software è molto lento e la roadmap che si erano proposti gli autori è ampiamente non rispettata. Nel mio caso, l’ultima versione rilasciata ha funzionato al primo colpo, consentendomi di tracciare con discreta facilità i grafici di cui ho bisogno. Il supporto per hardware “moderni” è decisamente scarso: i template non sono aggiornatissimi e bisognerebbe mettersi a scrivere il proprio, per coprire esigenze paricolari.

LibreNMS è un pacchetto software per il monitoraggio della rete molto accattivante. Si installa davvero facilmente, non richiede esoterismi particolari. Ha un interfaccia grafica molto gradevole e molto dinamica, lasciando il puntatore su un host, compaiono delle miniature dei grafici salienti.

nmt_01

nmt_02

Si possono configurare alerts, messaggi, e tutta una serie di features che rendono il prodotto particolarmente gradevole e abbastanza facile da usare. Il carico del POLLER sulla CPU del mio sistema si sente abbastanza, ma non ho mai avuto esperienza di rallentamenti o hang. Nella figura che segue, a sinistra il carico di sistema con LibreNMS+Cacti a destra solo con Cacti.

nmt_03

Attualmente ho configurato il sistema con Cacti, in quanto più leggero e maggiormente leggibile per me che lo uso da 3 o 4 anni. La scelta è tuttavia non definitiva, in quanto LibreNMS è ancora presente nel mio server, ho solo momentaneamente disabilitato il poller. Appena avrò tempo, voglio lavorere un po’ con gli alert per cercare qualche nuova feature.

Buon monitoraggi e ricordate di cambiare la default community SNMP quando installate un prodotto di rete!

Please follow and like us:
error

Applausi per (alice)fibra?

AGGIORNATO (vedi in basso)

Tutto inizia nel 2015, quando cedo all’offerta Telecom Italia per installare Alice Fibra. Arriva il tenico a casa, competente, cordiale e installa tutto. Provo la connessione, funziona a meraviglia. Faccio spazio nello studio rimuovendo l’AP, il vecchio router e confido nelle potenzialità del nuovo apparato Telecom.

Con qualche difficoltà configuro la connettività Wireless. Assegnare due SSID diversi è un po’ macchinoso ma, alla fine, ci riesco. Noto che il router funziona anche da media server, posso collegare un dispositivo esterno per fare lo “streaming” dei contenuti multimediali sulla rete. Fantastico, prendo il mio HD con qualche film dentro, lo collego e… nulla. Non funziona. Allora prendo una chiavetta. Nulla. Morale, non sono mai riuscito a fare funzionare il media server.

Configuro la rete cablata, per quanto la Wireless possa funzionare bene voglio la connessione Gigabit in rame. Collego tutti i cavi e … non funziona nulla. Non riesco nemmeno a pingare gli altri host. Riavvio il router, cambio le prese, cerco aggiornamenti, leggo i forum. Non ci sono versi. La connessione cablata su questo router è totalmente inaffidabile. Per spostare i dati sul NAS decido di connettermi con un cavo crossed. Faccio prima!

Ieri l’ultima perla. Tania guarda un film attingendo dal NAS. E’ un film vecchissimo in formato DIVX. Io vorrei navigare un po’. La connettività è altamente instabile. Perdo pacchetti. Imposto un ping verso il router, il NAS e google.

IMG_w3qwoi

Dopo 15 minuti la situazione è questa:

IMG_20150623_174255

Mando un tweet un po’ risentito taggando @telecomitalia . MI hanno risposto chiedendo delucidazioni sul problema. Vediamo come va a finire!

AGGIORNAMENTO 1: @Telecom187Luca ha aperto un ticket di assistenza. Ieri mi ha chiamato il tecnico ma ero fuori casa e, per un disguido, è stato risposto che “non ci sono problemi sulla linea” (cosa vera, la line ava bene è il router che non è il massimo).

AGGIORNAMENTO 2: Ho acquistato uno switch HP della serie Procurve e lo ho installato al posto di quello del router. Adesso anche se trasferisco 30GB verso il NAS (e lo faccio a circa 60MByte/s), posso navigare e fare altre operazioni sulla rete. QUesto conferma il mio sospetto sul non corretto funzionamento del dispositivo Telecom.

Please follow and like us:
error